Tuesday, July 01, 2008

DXCore Community Plugins (Suite)

Just a quick note to those following my blog, that I have uploaded a collective zip file containing the latest version of all community plugins to http://www.rorybecker.me.uk/DevExpress/Plugins/CommunitySuite/

This file has the postfix 1.0.0.90, which in keeping with it's contents, reflects the version of the repository as a whole which was used to generate the contents within.

 

We now return you to whatever you were doing before. :-)


16 comments:

andrew said...

hi rory,

i've got problems to install any of the plugins. As mentioned i copied the dll in the correct directory of DXCore (v3.08), but the as i (re)start vs2005 nothing happens. The plugin(s) doesn't seems to be loaded. Is there any trick or a switch which i don't know, to get it work?

Rory said...

Hi Andrew, sorry about the delay.

I'm afraid work is crazy busy at the moment.

I should have time to check this out this evening.

Again sorry for the delay

Andrew said...

never mind, thats not a problem, i'm glad for any help, so thanks for your efforts.

Rory said...

Ok I have just tested the latest CommunitySuite (version 103 - build in the last few minutes)

The HighlightCurrentLine plugin appeared to work correctly. ( Note this plugin can be disabled from the options screen under "Editor\Painting\CurrentLine"

I am however using VS2008. and I am also using a build of DXCore which is slightly ahead of the release build.

Some things to check.

1.> are you running under vista. If so then check (using explorer) if the dlls truely did extract to the folder you thought they did. Vista sometimes redirects writes that occur under the "Program files" directory.

Check also under "Editor\Code Modification\Catalog" for any "Code" items (ImplementBaseConstructors is a good one to look for)

Check also under "Editor\Refactoring\Catalog" for any "Refactoring" items (Generalize is a good one to look for)

Also be sure that Coderush was installed for VS2005 at all. do other "Official" Coderush/Refactor features work? if not... Is it possible that you installed the DX tools for VS2008 or VS2003 only, In which case they might not show up for VS2005.

Do let me know how you get on and I'll see if I can't help some more once you're done with this little lot.

Rory said...

While I think of it, Check you "DevExpress\ToolWindows\Diagnostics\Messages" window.

It's possible that there are some exceptions happening on load which may be being caught by this window which might give some clue as to what is happening.

Andrew said...

thank you rory for your help,

unfortuneatly i can't check your suggestions until moday.
But your explanations got me thinking.
First of all: Did coderush realy has to be installed to use the Community Plugins? Currently it isn't installed at all.
Further i use Refactor! Free 3.0.5 (i think) for vs2005 and it works quite good. But i don't longer know if Refactor comes in a bundle with dxcore or if i had to install it before installing Refactor. But it works.
So the feeling creeps over me that i can't use the dxcore community plugins with my current configuration right?

Rory said...

I will try removing Coderush from my machine over the weekend to see what happens.

However I do know that the project was started after the release of the 3.08 version of the tools was released.

So I suggest that the first thing to do would be to upgrade to DXCore/RefactorFree 3.08 and see what happens.

Rory said...

ok Andrew, I just popped along to see what the current version of RefactorFree was and it seems to be 3.05.

So I tried changing the link to http://downloads.devexpress.com/IDETools/VB/RefactorVB.NET-3.0.8.exe and what do ya know... the file does exist :)

This might help you. Let me know how it works out for you.

andrew said...

thanks again for the link,

i decided to do start from the bottom, so i deinstalled refactor and dxcore. Afterwards i' ve installed Refactor from the downloaded RefactorVB.NET-3.0.8.exe.

Next I've copied the HighlightCurrentLineInEditor.dll in the plugin directory of DXCore. Then I started vs2005, with the effect that refactor works but the currentLine is not highlighted. So the originally problem maintains.

In the next step i tried to follow your previous posts. The problem here is that i can't find the locations (e.g. Editor\Painting\CurrentLine, Editor\Refactoring\Catalog) you mentioned. Perhaps that's why i'm using a german-version of visual-studio (?) or perhaps something didn't install correctly.

I don't know what the problem could be and if you think it is going to get to complex to solve just tell me, that's no problem. I don't wana demand to much of your time. :-)

Rory said...

It sounds like the plugin is not loading at all.

Check the Messages toolwindow (mentioned in a previous comment)

If you like, save the contents of this log after fully loading VS and send it to me (RoryBecker[at]gmail[dot]com) and I'll see if I can find anything of note that might be slowing things down.

As for taking up too much of my time. I'm glad to help out when I can on things like this. I've gained so much through community of one kind or another that it's nice to be able to give something back on occasion. :)

I just hope we can find out what's giving you this issue.

andrew said...

You mean this hint:

While I think of it, Check you "DevExpress\ToolWindows\Diagnostics\Messages" window.

I can't find the location. Where should it be? Under Tools/Options or Edit/...?

Rory said...

Sounds like you do not have a top-level "DevExpress" menu item.

this would be normal for any version of DXCore/Coderush/RefactorPro

I wonder if this differs when using the RefactorFree version? I have very little experience with this.

Time to call in the big guns. I'm firing a message to Mark Miller.

Rory said...

Due to the apparent delay, I would think it reasonable that Mark is probably taking some well deserved chill time. I would at this point recommend contacting support@devexpress.com. they are very good at sorting out this sort of problem.

Feel free to pass them my email address (rorybecker[at]gmail[dot]com) and/or link them through to this post in connection with this problem.

Let me know how things go.

andrew said...

Ok, thanks

I' ll do so.

andrew said...

Hi Rory,

I've got an answer from support:

As far as I know, free versions of our tools are not extensible. I.e. they don't support custom plugins. Please install the evaluation versions of CodeRush and Refactor!, and try those plugins.

So it's not possible to use comunity plugins with Refactor! Free at all.
They pointed to install the evaluation versions which i did. Afterwards i copied the HighlightCurrentLineInEditor.dll in the plugins-directory of DX Core, start vs2005 and enabled Current Line Highlighting. As result nothing happens. No line gets highlighted at all. But i got an error:
TextView.GetPoint(): Could not retrieve client-point of text location 5,0. An HRESULT of E_FAIL (0x80004005) was returned.
in the Messages window. If you want i'll send you the logfile. I post a similar message as update to support. You can find it here.
There you can find the logfile too.

Rory said...

Sorry Andrew, your last post did carry the link properly.

Feel free to zip and email me(RoryBecker[at]Gmail[dot]com) the log file in question together with a reference to the issue you have filed with support if available.

I am building a VM as we speak with which to try the scenario you currently have.

Hopefully we will discover what is going on.